Skip to content
View in the app

A better way to browse. Learn more.

Armbian Community Forums

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

lightdm crashes after recent upgrade

Featured Replies

After last apt upgrade (v21.05.4), lightdm on a RockPro64 does not start anymore.

 

rockpro64:~:# systemctl status lightdm.service   
● lightdm.service - Light Display Manager
     Loaded: loaded (/lib/systemd/system/lightdm.service; indirect; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sun 2021-06-20 16:13:01 CEST; 21min ago
       Docs: manlightdm(1)
    Process: 1877 ExecStartPre=/bin/sh -c [ "$(basename $(cat /etc/X11/default-display-manager 2>/dev/null))" = "lightdm" ] (code=exited, status=0/SUCCESS)
    Process: 1880 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 1880 (code=exited, status=1/FAILURE)

Jun 20 16:13:01 rockpro64 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Jun 20 16:13:01 rockpro64 systemd[1]: Stopped Light Display Manager.
Jun 20 16:13:01 rockpro64 systemd[1]: lightdm.service: Start request repeated too quickly.
Jun 20 16:13:01 rockpro64 systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jun 20 16:13:01 rockpro64 systemd[1]: Failed to start Light Display Manager.

 

and trying to start manually as root

 

rockpro64:~:# systemctl start lightdm.service 
Job for lightdm.service failed because the control process exited with error code.
See "systemctl status lightdm.service" and "journalctl -xe" for details.
rockpro64:~:# journalctl -xe 
Jun 20 16:36:33 rockpro64 systemd[1]: Failed to start Light Display Manager.
-- Subject: A start job for unit lightdm.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- A start job for unit lightdm.service has finished with a failure.
-- 
-- The job identifier is 1583 and the job result is failed.
Jun 20 16:36:33 rockpro64 systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
-- Subject: Automatic restarting of a unit has been scheduled
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Automatic restarting of the unit lightdm.service has been scheduled, as the result for
-- the configured Restart= setting for the unit.
Jun 20 16:36:33 rockpro64 systemd[1]: Stopped Light Display Manager.
-- Subject: A stop job for unit lightdm.service has finished
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- A stop job for unit lightdm.service has finished.
-- 
-- The job identifier is 1648 and the job result is done.
Jun 20 16:36:33 rockpro64 systemd[1]: lightdm.service: Start request repeated too quickly.
Jun 20 16:36:33 rockpro64 systemd[1]: lightdm.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- The unit lightdm.service has entered the 'failed' state with result 'exit-code'.
Jun 20 16:36:33 rockpro64 systemd[1]: Failed to start Light Display Manager.
-- Subject: A start job for unit lightdm.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- A start job for unit lightdm.service has finished with a failure.
-- 
-- The job identifier is 1648 and the job result is failed.

 

running lightdm as root with debug enabled

 

rockpro64:~:# lightdm --debug                    
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=3791
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /root/.local/share/flatpak/exports/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/10-slick-greeter.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf.d/11-armbian.conf
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.19s] DEBUG: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ?gio-vfs?
[+0.20s] DEBUG: Monitoring logind for seats
[+0.20s] DEBUG: New seat added from logind: seat0
[+0.20s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.20s] DEBUG: Seat seat0: Starting
[+0.20s] DEBUG: Seat seat0: Creating greeter session
[+0.20s] DEBUG: Seat seat0: Failed to find session configuration slick-greeter
[+0.20s] DEBUG: Seat seat0: Failed to create greeter session
[+0.20s] DEBUG: Failed to start seat: seat0

 

Any ideas how to drill further down the problem?

Solved by Igor

  • Author

Hi Igor, thanks for the heads up, this fixed it.

 

Just out of curiosity, as lightdm worked until the upgrade. Has the slick-greeter been added recently to armbian? I did not remove it intentionally.

On 6/20/2021 at 5:50 PM, Igor said:

 

Try perhaps this: 

apt install slick-greeter

+ reboot.

@Igor I also got lightdm-problems while installing my Ordroid C2 from scratch
(2 times once with current and once with edge)

After trying different soutions from the net it didnt worked....BUT with a simple "enable Desktop" from armbian-config -> System-settings and the desktop did start again without any problems :)

On 6/27/2021 at 5:56 AM, guidol said:

@Igor I also got lightdm-problems while installing my Ordroid C2 from scratch
(2 times once with current and once with edge)

After trying different soutions from the net it didnt worked....BUT with a simple "enable Desktop" from armbian-config -> System-settings and the desktop did start again without any problems :)

After lightdm fails on my Pinebook Pro, I simply logon to the terminal and

 

startx

 

but I will try slick-greeter.

 

I could not find the "enable Desktop" from armbian-config -> System-settings, which I assume is an Applications menu hierarchy.

 

Thanks!

Edited by calinb

On 6/20/2021 at 10:50 AM, Igor said:

 

Try perhaps this: 

apt install slick-greeter

+ reboot.

 

On 6/27/2021 at 8:56 AM, guidol said:

@Igor I also got lightdm-problems while installing my Ordroid C2 from scratch
(2 times once with current and once with edge)

After trying different soutions from the net it didnt worked....BUT with a simple "enable Desktop" from armbian-config -> System-settings and the desktop did start again without any problems :)

 

Thanks Igor, guidol. Installing slick-greeter worked for me too.

This happened to me as well on a Pine64 yesterday. Installing slick-greeter solved it as well. Thanks.

Guest
This topic is now closed to further replies.

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.