April 18, 20242 yr Orange Pi 5 plus. It seems that in the 'edge' kernels, ssh is disabled by default. Since HDMI doesn't function this is a problem. I used the debugging UART and after setup I got the message "ssh.service is disabled" I enabled the service and all is well. Any reason why ssh would be disabled?
April 18, 20242 yr moved ssh is enabled by default on all images. Check if there is further information in journal why it did not start.
April 18, 20242 yr Author Here is the partial boot log Starting ssh.service - OpenBSD Secure Shell server... sshd: no hostkeys available -- exiting. ssh.service: Control process exited, code=exited, status=1/FAILURE ssh.service: Failed with result 'exit-code'. Failed to start ssh.service - OpenBSD Secure Shell server. ssh.service: Scheduled restart job, restart counter is at 1. Starting ssh.service - OpenBSD Secure Shell server... sshd: no hostkeys available -- exiting. Not sure what to do as keys have not been generated yet. Thanks, Bill
April 18, 20242 yr have you tried to run dpkg-reconfigure openssh-server so a fresh bunch of keys is being generated? Seems like for some reason key generation fails on first boot....
April 18, 20242 yr Author After first boot and initial setup and login, I can enable and start the openssh server with no problem. I'm not sure how generating a set of new keys would help. This happens with numerous images. Armbian_24.5.0-trunk.429_Orangepi5-plus_trixie_edge_6.8.6_minimal.img Armbian_24.5.0-trunk.429_Orangepi5-plus_trixie_vendor_6.1.43_minimal.img Among others. Legacy image with 5.10.160 kernel does not have this problem Regards Bill
April 18, 20242 yr Author Werner Looks like it's just trixie. built an image with Bookworm (bookworm_edge_6.8.7_minimal) and works with no issues so far Bill
April 19, 20242 yr Ah okay. Trixie is an unsupported userspace anyways. So this might be fixed at some point on the way when it reaches stable.
April 26, 20242 yr A while ago I debugged the ssh problem and added some comments in this thread here. I don't remember if I used bookworm or trixie. Seems to me a timing issue or in which order things start. For now, whenever I do some dev work, I just do either another reboot after the first setup or restart the sshd service.
Join the conversation
You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.